OCS Inventory NG Forums

OCS Inventory NG, an OpenSource computer inventory and package deployement system for Windows and Unix

You are not logged in.

#1 2011-05-23 09:28:55

loopin3
Member
Registered: 2011-05-23
Posts: 14

OCSInventory Error

Hi all, i have installed the last version of OCS agent for windows on windows xp pro... when i launch the agent i have a error in event viewer application fault ntdll.dll error 0x00036a12...
Can you help me please????

tanks..

Offline

#2 2011-05-23 10:43:29

loopin3
Member
Registered: 2011-05-23
Posts: 14

Re: OCSInventory Error

ok i have solved this with agent versione 2.0.0.RC1 candidate but i have a problem with autentication... Server is a windwox with xampp and agent return post response from server http status code 200...
How i can resolve this???
tanks.

Offline

#3 2011-05-23 10:58:36

frankb
OCS Team
From: France (Angers)
Registered: 2009-01-12
Posts: 3,579
Website

Re: OCSInventory Error

Hi,

Download the stable version of the agent. Code 200 means that the inventory has been sent to the server successfully. You now can see the inventoried machine in the web console of the server.

Offline

#4 2011-05-23 11:02:51

loopin3
Member
Registered: 2011-05-23
Posts: 14

Re: OCSInventory Error

ok.. but i dont see a machine in webconsole.. why if 200 is ok?

Offline

#5 2011-05-23 11:18:08

frankb
OCS Team
From: France (Angers)
Registered: 2009-01-12
Posts: 3,579
Website

Re: OCSInventory Error

Can you post the content of the ocsinventory.ini file, located in c:\programdata\ocs inventory ng\agent and in c:\documents and settings\all users\application data\ocs inventory ng\agent?
I think you have a mistake in this file.

Offline

#6 2011-05-23 11:25:19

loopin3
Member
Registered: 2011-05-23
Posts: 14

Re: OCSInventory Error

[OCS Inventory Agent]
ComProvider=ComHTTP.dll
Debug=1
Local=
HKCU=0
NoTAG=0
IpDisc=

[HTTP]
Server=http://192.168.1.7/ocsreports
SSL=0
CaBundle=cacert.pem
AuthRequired=1
User=
Pwd=
ProxyType=0
Proxy=
ProxyPort=0
ProxyAuthRequired=1
ProxyUser=
ProxyPwd=

[OCS Inventory Service]
TTO_WAIT=35340
PROLOG_FREQ=10
OLD_PROLOG_FREQ=10

Offline

#7 2011-05-23 11:31:21

frankb
OCS Team
From: France (Angers)
Registered: 2009-01-12
Posts: 3,579
Website

Re: OCSInventory Error

Change Server=http://192.168.1.7/ocsreports to Server=http://192.168.1.7/ocsinventory and Debug=1 to Debug=2. Save the file and restart the service. Launch a new inventory and your machine will appear on the server.

Offline

#8 2011-05-23 11:35:00

loopin3
Member
Registered: 2011-05-23
Posts: 14

Re: OCSInventory Error

with ocsinventory have a 404 http error. my address webconsole is http://192.168.1.7/ocsreports and ocsinventory...

Offline

#9 2011-05-23 13:25:18

frankb
OCS Team
From: France (Angers)
Registered: 2009-01-12
Posts: 3,579
Website

Re: OCSInventory Error

So your perl module is not activated.
Check your apache configuration and see if you can find mod_perl.so in it. I assume that you have a linux server.

Offline

#10 2011-05-23 13:29:37

loopin3
Member
Registered: 2011-05-23
Posts: 14

Re: OCSInventory Error

ok... i have restarted apache (xampp-windows) and want start because dont have activated perl module.... I remove all and reinstall all :-(
tank you for information..

Offline

#11 2011-05-23 14:05:00

loopin3
Member
Registered: 2011-05-23
Posts: 14

Re: OCSInventory Error

i have  a fresh installation of xampp and ocs but i have a same problem... the perlinfo() work but when i launch inventory have a http status 200 and the computer is not inventoried in web console...why??
tanks

Offline

#12 2011-05-23 14:20:46

Jyru-Ken
Moderator
Registered: 2010-09-17
Posts: 585

Re: OCSInventory Error

Could you post your logs files ( server and agent ) with debug=2 ?

Offline

#13 2011-05-23 14:21:48

loopin3
Member
Registered: 2011-05-23
Posts: 14

Re: OCSInventory Error

tarting OCS Inventory NG Agent on Monday, May 23, 2011 14:54:11.
AGENT => Running OCS Inventory NG Agent Version 2.0.0.20
AGENT => Using OCS Inventory NG FrameWork Version 2.0.0.20
AGENT => Loading plug-in(s)
    PLUGIN => Searching for Plug-in DLL(s) in folder <C:\Program Files (x86)\OCS Inventory Agent\plugins>
    PLUGIN => 0 Plug-in(s) succesfully loaded
AGENT => Using network connection with Communication Server
    COM PROVIDER => Loading Communication Provider <C:\Program Files (x86)\OCS Inventory Agent\ComHTTP.dll>
AGENT => Using Communication Provider <OCS Inventory NG cURL Communication Provider> Version <2.0.0.20>
    AGENT => Tag forced by /TAG, value is <Tresol>
AGENT => Sending Prolog
    DID_CHECK => Read DeviceID <LUPIN3-2011-05-23-13-39-21> and MACs <54:42:49:EB:49:0300:27:10:91:60:F000:50:56:C0:00:0100:50:56:C0:00:08> in file <ocsinventory.dat>
    COM SERVER => Initializing cURL library for sendRequest
    COM SERVER => Using cURL with server authentication
    COM SERVER => Disabling cURL proxy support
    COM SERVER => Disabling cURL SSL server validation support
    COM SERVER => Sending HTTP Post request to URL <http://192.168.1.7/ocsreports>
    COM SERVER => HTTP Post response received <HTTP Status Code #200>
    COM SERVER => Cleaning cURL library
================= TRACE START ===============

================= TRACE STOP ===============
AGENT => Prolog successfully sent
SUPPORT => No support detected, Registration key : N/A
    AGENT => Prolog Frequency set to 10 hour(s)
AGENT => Inventory forced by /FORCE option
AGENT => Launching hardware and software checks
    INVENTORY => Loading Download history
    INVENTORY => Logged on user ID is <Rosario Iameo>
    INVENTORY => Operating System is <Microsoft Windows 7 Home Premium 6.1.7600 >, description <>
    INVENTORY => Operating System uses 64 bits memory address width
    INVENTORY => Computer domain or workgroup is <WORKGROUP>
    WARNING *** INVENTORY => Failed to retrieve user domain
    INVENTORY => System Manufacturer <Sony Corporation>, System Model <VPCF13M1E>, System S/N <27530861-5000741>, Bios Manufacturer <American Megatrends Inc.>, Bios Date <09/03/2010>, Bios Version <R0180Y9>
    INVENTORY => 1 processor(s) Intel(R) Core(TM) i5 CPU       M 560  @ 2.67GHz [2 core(s) x64] at 2667 MHz
    INVENTORY => OS Memory 4013 MB, OS Swap size 8024 MB
    INVENTORY => 2 memory slot(s) found
    INVENTORY => 3 input device(s) found
    INVENTORY => 16 system port(s) found
    WARNING *** INVENTORY => Failed to retrieve system slots
    INVENTORY => 9 system controler(s) found
    INVENTORY => 5 storage peripheral(s) found
    INVENTORY => 5 sound device(s) found
    INVENTORY => 5 modem(s) found
    INVENTORY => 4 network adapter(s) found
    INVENTORY => 9 system printer(s) found
    INVENTORY => 1 video adapter(s) found
    INVENTORY => 1 system monitor(s) found
    INVENTORY => Default IPv4 address is <192.168.1.25>
    INVENTORY => Registered company <>, registered owner <Rosario Iameo>, Product ID <00359-OE...>
    INVENTORY => Product key <H4JWX-WH...>
    INVENTORY => 1031 software found
    INVENTORY => Computer/VM UUID is <45DEE980-F61D-11DE-81E2-544249EB4903>
    INVENTORY => Computer seems to be physical host
    INVENTORY => Bogus summed Memory Slots, 4096 is too far from 4013 (keeping the last one)
    INVENTORY => Reading last inventory state
    EXECUTABLE PLUGIN => Searching for VBS script(s) in folder <C:\Program Files (x86)\OCS Inventory Agent\plugins>
    EXECUTABLE PLUGIN => Searching for executable(s) in folder <C:\Program Files (x86)\OCS Inventory Agent\plugins>
AGENT => Sending Inventory
    INVENTORY => Checking last inventory state
INVENTORY => No change since last inventory
    INVENTORY => Generating XML document with Device properties
    INVENTORY => XML Update 2 Logical Drive(s)
    INVENTORY => XML Update common Device properties
    INVENTORY => XML Update BIOS
    INVENTORY => XML Update 3 Input Device(s)
    INVENTORY => XML Update 16 System Port(s)
    INVENTORY => XML Update 9 System Controler(s)
    INVENTORY => XML Update 0 System Slot(s)
    INVENTORY => XML Update 5 Sound Device(s)
    INVENTORY => XML Update 5 Storage Peripheral(s)
    INVENTORY => XML Update 5 Logical Drive(s)
    INVENTORY => XML Update 5 Modem(s)
    INVENTORY => XML Update 4 Network Adapter(s)
    INVENTORY => XML Update 1 Video Adapter(s)
    INVENTORY => XML Update 1 Monitor(s)
    INVENTORY => XML Update 9 Printer(s)
    INVENTORY => XML Update 1032 Software
    INVENTORY => XML Update 0 Registry Value(s)
    INVENTORY => XML Update Administrative Information(s)
    COM SERVER => Initializing cURL library for sendRequest
    COM SERVER => Using cURL with server authentication
    COM SERVER => Disabling cURL proxy support
    COM SERVER => Disabling cURL SSL server validation support
    COM SERVER => Sending HTTP Post request to URL <http://192.168.1.7/ocsreports>
    COM SERVER => HTTP Post response received <HTTP Status Code #200>
    COM SERVER => Cleaning cURL library
================= TRACE START ===============

================= TRACE STOP ===============
AGENT => Inventory successfully sent
    INVENTORY => Writing new inventory state
AGENT => Unloading communication provider
AGENT => Unloading plug-in(s)
AGENT => Execution duration: 00:00:05.

Offline

#14 2011-05-23 14:22:17

frankb
OCS Team
From: France (Angers)
Registered: 2009-01-12
Posts: 3,579
Website

Re: OCSInventory Error

what url have you setup in the ocsinventor.ini file?

Offline

#15 2011-05-23 14:23:31

loopin3
Member
Registered: 2011-05-23
Posts: 14

Re: OCSInventory Error

log of apache????

Offline

#16 2011-05-23 14:24:32

loopin3
Member
Registered: 2011-05-23
Posts: 14

Re: OCSInventory Error

Offline

#17 2011-05-23 14:25:42

loopin3
Member
Registered: 2011-05-23
Posts: 14

Re: OCSInventory Error

192.168.1.25 - - [23/May/2011:15:24:57 +0200] "POST /ocsreports HTTP/1.1" 301 382 "-" "OCS-NG_WINDOWS_AGENT_v2.0.0.20"
192.168.1.25 - - [23/May/2011:15:24:57 +0200] "GET /ocsreports/ HTTP/1.1" 200 3473 "-" "OCS-NG_WINDOWS_AGENT_v2.0.0.20"

Offline

#18 2011-05-23 14:25:44

frankb
OCS Team
From: France (Angers)
Registered: 2009-01-12
Posts: 3,579
Website

Re: OCSInventory Error

change to http://192.168.1.7/ocsinventory. Save the file and restart the service ocsinventory.
Launch an inventory

Offline

#19 2011-05-23 14:29:04

loopin3
Member
Registered: 2011-05-23
Posts: 14

Re: OCSInventory Error

if ia launch ocsinventory.exe from cmd with http://192.168.1.7/ocsinventory i have a
Starting OCS Inventory NG Agent on Monday, May 23, 2011 15:27:40.
AGENT => Running OCS Inventory NG Agent Version 2.0.0.20
AGENT => Using OCS Inventory NG FrameWork Version 2.0.0.20
AGENT => Loading plug-in(s)
    PLUGIN => Searching for Plug-in DLL(s) in folder <C:\Program Files (x86)\OCS Inventory Agent\plugins>
    PLUGIN => 0 Plug-in(s) succesfully loaded
AGENT => Using network connection with Communication Server
    COM PROVIDER => Loading Communication Provider <C:\Program Files (x86)\OCS Inventory Agent\ComHTTP.dll>
AGENT => Using Communication Provider <OCS Inventory NG cURL Communication Provider> Version <2.0.0.20>
    AGENT => Tag forced by /TAG, value is <Tresol>
AGENT => Sending Prolog
    DID_CHECK => Read DeviceID <LUPIN3-2011-05-23-13-39-21> and MACs <54:42:49:EB:49:0300:27:10:91:60:F000:50:56:C0:00:0100:50:56:C0:00:08> in file <ocsinventory.dat>
    COM SERVER => Initializing cURL library for sendRequest
    COM SERVER => Using cURL with server authentication
    COM SERVER => Disabling cURL proxy support
    COM SERVER => Disabling cURL SSL server validation support
    COM SERVER => Sending HTTP Post request to URL <http://192.168.1.7/ocsinventory>
    COM SERVER => HTTP Post response received <HTTP Status Code #404>
    COM SERVER => Cleaning cURL library
================= TRACE START ===============

================= TRACE STOP ===============
ERROR *** AGENT => Failed to send Prolog <HTTP Status Code #404>
AGENT => Unloading communication provider
AGENT => Unloading plug-in(s)
AGENT => Execution duration: 00:00:02.

Offline

#20 2011-05-23 14:36:11

frankb
OCS Team
From: France (Angers)
Registered: 2009-01-12
Posts: 3,579
Website

Re: OCSInventory Error

Question: your ocs server is linux or windows?

Offline

#21 2011-05-23 14:36:31

loopin3
Member
Registered: 2011-05-23
Posts: 14

Re: OCSInventory Error

windows-xampp

Offline

#22 2011-05-23 14:38:36

loopin3
Member
Registered: 2011-05-23
Posts: 14

Re: OCSInventory Error

i have installed a full ocs package that install a ocs and xampp......

Offline

Board footer

Powered by FluxBB