OCS Inventory NG Forums

OCS Inventory NG, an OpenSource computer inventory and package deployement system for Windows and Unix

You are not logged in.

#1 2010-11-16 12:01:05

teckboy62
Top member
Registered: 2009-11-03
Posts: 119

You don't have permission to access /download/ on this server.

Hi,
I can't make teledepoyment on my server.
When i try to connect to "download" directory, i get this message from Firefox

"You don't have permission to access /download/ on this server."

What ca i do?

Offline

#2 2010-11-16 12:17:39

kapouik
Administrator and OCS Team
From: Pink Town (South of France)
Registered: 2010-06-16
Posts: 3,393
Website

Re: You don't have permission to access /download/ on this server.

you can give us the log file of apache (access and error). You can say us What OS/Distribution you use. You can say us what version of OCS do you use and how do you have install it. You can give us lot of money because we are really nice.

You have lot of choice !


Before asking any questions please read the documentation on http://wiki.ocsinventory-ng.org/ . No help will be given if you have not read this two pages :
- http://wiki.ocsinventory-ng.org/index.p … ion:Newbie
- http://wiki.ocsinventory-ng.org/index.p … n:Main#FAQ
OCS Inventory NG is made by a team of volunteers on our free time.

Offline

#3 2010-11-16 12:24:57

bezourox
OCS Team
Registered: 2009-11-17
Posts: 1,619
Website

Re: You don't have permission to access /download/ on this server.

wink
More seriously, probably a problem in your apache configuration.
Check the definition of the alias download in ocsinventory-reports.conf.
Or maybe a problem of permissions on the directory "download"


IRC : #ocsinventory-ng @ chat.freenode.net
Documentation : http://wiki.ocsinventory-ng.org
Reference your company on http://www.ocsinventory-ng.org/en/commu … ences.html

Offline

#4 2010-11-16 13:45:18

teckboy62
Top member
Registered: 2009-11-03
Posts: 119

Re: You don't have permission to access /download/ on this server.

My server is on Debian, version of OCS is 1.3.2

in /etc/apache2/conf.d/ocsinventory-reports.conf i can see :

Alias /download /var/lib/ocsinventory-reports/download


I can see that in the access.log

******** - - [16/Nov/2010:13:42:02 +0100] "GET /download/ HTTP/1.1" 403 300 "-" "Mozilla/5.0 (Windows; U; Windows NT 6.1; fr; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12"
******** - - [16/Nov/2010:13:42:03 +0100] "GET /download/ HTTP/1.1" 403 300 "-" "Mozilla/5.0 (Windows; U; Windows NT 6.1; fr; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12"
******** - - [16/Nov/2010:13:42:03 +0100] "GET /download/ HTTP/1.1" 403 300 "-" "Mozilla/5.0 (Windows; U; Windows NT 6.1; fr; rv:1.9.2.12) Gecko/20101026 Firefox/3.6

And in the error.log

[Tue Nov 16 13:42:02 2010] [error] [client ********] Directory index forbidden by Options directive: /var/lib/ocsinventory-reports/download/
[Tue Nov 16 13:42:03 2010] [error] [client ********] Directory index forbidden by Options directive: /var/lib/ocsinventory-reports/download/
[Tue Nov 16 13:42:03 2010] [error] [client ********] Directory index forbidden by Options directive: /var/lib/ocsinventory-reports/download/

Offline

#5 2010-11-16 14:00:33

teckboy62
Top member
Registered: 2009-11-03
Posts: 119

Re: You don't have permission to access /download/ on this server.

it's done!!!!

I've writed this after Alias /download....

<Directory /var/lib/ocsinventory-reports/download/>
Order deny,allow
Allow from all
Options Indexes FollowSymLinks
AllowOverride Options
</Directory>

So now i can't connect in HTTPS...

Offline

#6 2010-11-16 14:01:56

bezourox
OCS Team
Registered: 2009-11-17
Posts: 1,619
Website

Re: You don't have permission to access /download/ on this server.

My Alias "download"

################################################################################
# Deployment packages download area
#
# Alias to put Deployement package files outside Apache document root directory
#
Alias /download /var/lib/ocsinventory-reports/download
<Directory /var/lib/ocsinventory-reports/download>
    # By default, users can use console from everywhere
    Order deny,allow
    Allow from all
    Options Indexes FollowSymLinks
    DirectoryIndex index.php
    AllowOverride Options
   
    # Uncomment following to force use of HTTPS in Administration Server
    #SSLRequireSSL
   
    # PHP tuning (not working on all distribution, use php.ini instead)
    AddType application/x-httpd-php .php
    php_flag file_uploads           on
    # Some PHP tuning for deployement feature up to 8 MB
    # post_max_size must be greater than upload_max_filesize
    # because of HTTP headers
    php_value post_max_size         490m
    php_value upload_max_filesize   480m
    # You may have to uncomment following on errors
    #php_value max_execution_time -1
    #php_value max_input_time -1

    # Uncomment following to allow HTTP body request up to 4 MB
    # instead default 512 KB
    #LimitRequestBody 4194304
</Directory>

Correct yours, restart apache2, and enjoy


IRC : #ocsinventory-ng @ chat.freenode.net
Documentation : http://wiki.ocsinventory-ng.org
Reference your company on http://www.ocsinventory-ng.org/en/commu … ences.html

Offline

#7 2010-11-16 14:06:50

frankb
OCS Team
From: France (Angers)
Registered: 2009-01-12
Posts: 3,601
Website

Re: You don't have permission to access /download/ on this server.

don't forget to copy the certificate file on each clients, otherwise the download will not function. smile

Offline

#8 2010-11-16 14:29:02

teckboy62
Top member
Registered: 2009-11-03
Posts: 119

Re: You don't have permission to access /download/ on this server.

each client get already ocs client by GPO so certificat is already setup

Offline

#9 2010-11-16 14:29:52

frankb
OCS Team
From: France (Angers)
Registered: 2009-01-12
Posts: 3,601
Website

Re: You don't have permission to access /download/ on this server.

Nice

Offline

#10 2010-11-16 14:37:32

teckboy62
Top member
Registered: 2009-11-03
Posts: 119

Re: You don't have permission to access /download/ on this server.

Sorry but i don't understand how to use https adress....

Offline

#11 2010-11-16 14:58:53

kapouik
Administrator and OCS Team
From: Pink Town (South of France)
Registered: 2010-06-16
Posts: 3,393
Website

Re: You don't have permission to access /download/ on this server.

That's really simple : for exemple with http://www.google.com :
Just put https instead of http like that : https://www.google.com


Before asking any questions please read the documentation on http://wiki.ocsinventory-ng.org/ . No help will be given if you have not read this two pages :
- http://wiki.ocsinventory-ng.org/index.p … ion:Newbie
- http://wiki.ocsinventory-ng.org/index.p … n:Main#FAQ
OCS Inventory NG is made by a team of volunteers on our free time.

Offline

#12 2010-11-16 15:13:49

bezourox
OCS Team
Registered: 2009-11-17
Posts: 1,619
Website

Re: You don't have permission to access /download/ on this server.

Be clear in your questions please...

The first problem was to access to download directory @ http://server/download
With the configuration I did before, is it okey ?

After that, you indeed have to configure SSL on your server to use deployment's function.

Look here for exemple, or directly in google witch is your friend smile

http://wiki.ocsinventory-ng.org/index.p … bian_Lenny


IRC : #ocsinventory-ng @ chat.freenode.net
Documentation : http://wiki.ocsinventory-ng.org
Reference your company on http://www.ocsinventory-ng.org/en/commu … ences.html

Offline

#13 2010-11-16 16:29:13

teckboy62
Top member
Registered: 2009-11-03
Posts: 119

Re: You don't have permission to access /download/ on this server.

Ok, i'll try to follow this "howto"

Offline

#14 2010-11-16 16:55:00

teckboy62
Top member
Registered: 2009-11-03
Posts: 119

Re: You don't have permission to access /download/ on this server.

i've followed all the tuto

When i try to activate ssl, i get this message

"Site SSL does not exist"

I've created a file called "SSL" under /etc/apache2/site-enabled

this is what i've put on this file:

#NameVirtualHost *:443
<VirtualHost srv-ocs:443>
       
DocumentRoot /var/lib/ocsinventory-reports
        <Directory />
                Options FollowSymLinks
                AllowOverride None
        </Directory>
        <Directory /var/lib/ocsinventory-reports/>
                Options Indexes FollowSymLinks MultiViews
                AllowOverride None
                Order allow,deny
                allow from all
        </Directory>
        ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
        <Directory "/usr/lib/cgi-bin">
                AllowOverride None
                Options ExecCGI -MultiViews +SymLinksIfOwnerMatch
                Order allow,deny
                Allow from all
        </Directory>
        ErrorLog /var/log/apache2/error.log
        # Possible values include: debug, info, notice, warn, error, crit,
        # alert, emerg.
        LogLevel warn
        SSLEngine On
        SSLCipherSuite ALL:!ADH:!EXPORT56:RC4+RSA:+HIGH:+MEDIUM:+LOW:+SSLv2:+EXP:+eNULL
        SSLCertificateKeyFile /etc/apache2/ssl/server.key
        SSLCertificateFile /etc/apache2/ssl/server.crt
        CustomLog /var/log/apache2/access.log combined
        ServerSignature On
    Alias /doc/ "/usr/share/doc/"
    <Directory "/usr/share/doc/">
        Options Indexes MultiViews FollowSymLinks
        AllowOverride None
        Order deny,allow
        Deny from all
        Allow from 127.0.0.0/255.0.0.0 ::1/128
    </Directory>
</VirtualHost>

sorry but i'm a begginer on linux....

Offline

#15 2010-11-16 16:55:50

bezourox
OCS Team
Registered: 2009-11-17
Posts: 1,619
Website

Re: You don't have permission to access /download/ on this server.

This HowTo is perfect, and the editor, too wink


IRC : #ocsinventory-ng @ chat.freenode.net
Documentation : http://wiki.ocsinventory-ng.org
Reference your company on http://www.ocsinventory-ng.org/en/commu … ences.html

Offline

#16 2010-11-16 16:58:59

frankb
OCS Team
From: France (Angers)
Registered: 2009-01-12
Posts: 3,601
Website

Re: You don't have permission to access /download/ on this server.

a2ensite ssl to validate the ssl site. Restart apache after. smile

Offline

#17 2010-11-16 17:02:04

bezourox
OCS Team
Registered: 2009-11-17
Posts: 1,619
Website

Re: You don't have permission to access /download/ on this server.

I've created a file called "SSL" under /etc/apache2/site-enabled

In wiki :

Création du fichier /etc/apache2/sites-available/ssl avec le contenu suivant...

You create the file in the bad directory...
Search on google "howto" activate SSL on linux" if you don't understand french (documentation not yet translate)


IRC : #ocsinventory-ng @ chat.freenode.net
Documentation : http://wiki.ocsinventory-ng.org
Reference your company on http://www.ocsinventory-ng.org/en/commu … ences.html

Offline

#18 2010-11-16 17:06:47

teckboy62
Top member
Registered: 2009-11-03
Posts: 119

Re: You don't have permission to access /download/ on this server.

je suis francais... smile désolé erreur de lecture, je test.... ^^

Offline

#19 2010-11-16 17:10:06

bezourox
OCS Team
Registered: 2009-11-17
Posts: 1,619
Website

Re: You don't have permission to access /download/ on this server.

OK.
OCS Inventory, c'est français, tous les membres de la team sont français je pense, et il y a un forum séparé en 2 : FRANCAIS et ANGLAIS wink
Ensuite si tu en profite pour améliorer ton anglais, pas de souci big_smile


IRC : #ocsinventory-ng @ chat.freenode.net
Documentation : http://wiki.ocsinventory-ng.org
Reference your company on http://www.ocsinventory-ng.org/en/commu … ences.html

Offline

#20 2010-11-16 17:14:56

teckboy62
Top member
Registered: 2009-11-03
Posts: 119

Re: You don't have permission to access /download/ on this server.

ba jpensais que j'aurais plus de réponse en anglais, et par la même occasion, en effet je bosse mon Anglais...
Sinon, j'accede a https://@ de mon serveur/download ^^

Donc je pense que tout est OK! ^^

Merci!!

Offline

#21 2010-11-16 17:22:24

bezourox
OCS Team
Registered: 2009-11-17
Posts: 1,619
Website

Re: You don't have permission to access /download/ on this server.

Tout est ok.
Dans l'interface web, il faut que tu active le déploiement en passant par : Onglet Configuration (Clée à molette) > "Configuration" > Onglet "Télédéploiement" > Passer DONWLOAD ET DEPLOY  à ON.

Pour créer des paquets, tu as le wiki (partie AdminCenter).


IRC : #ocsinventory-ng @ chat.freenode.net
Documentation : http://wiki.ocsinventory-ng.org
Reference your company on http://www.ocsinventory-ng.org/en/commu … ences.html

Offline

#22 2010-11-17 08:47:03

teckboy62
Top member
Registered: 2009-11-03
Posts: 119

Re: You don't have permission to access /download/ on this server.

Me revoilà! alors, mon paquet est créée, activé, j'ai sélectionné les machines sur lesquelles il doit etre lancer. En revanche, je vois 10 machines notifiées, mais aucune remonté, ni en erreurs, ni en success...Mes pc sont resté allumés la nuit.
Il s'agit de la mise a jour flash player que je voudrais faire passer par OCS pour ne pas avoir à me loguer en admin sur chaque poste pour la faire...
En revanche, est ce que je dois créer un package comme pour l'ocs Agent???

Offline

#23 2010-11-17 09:05:05

frankb
OCS Team
From: France (Angers)
Registered: 2009-01-12
Posts: 3,601
Website

Re: You don't have permission to access /download/ on this server.

As-tu copié le certificat du serveur sur les postes clients? Poste le contenu du fichier log d'un des clients.

Offline

#24 2010-11-17 09:37:05

teckboy62
Top member
Registered: 2009-11-03
Posts: 119

Re: You don't have permission to access /download/ on this server.

Mes clients ont deja un certificat puisque les OCS agent descendent du serveur...

Voici le contenu de mon download.log

C:\Program Files\OCS Inventory Agent    -    Starting on Wednesday, November 17, 2010 08:36:41...
Command line parameters: <</SERVER:192.168.2.2 /PNUM:80 /NP /DEBUG >>
C:\Program Files\OCS Inventory Agent\download    -    
C:\Program Files\OCS Inventory Agent\download    -    1289900806 directory parsing...
C:\Program Files\OCS Inventory Agent\download    -            ERROR: Can't open 1289900806\info
C:\Program Files\OCS Inventory Agent\download    -    Cleaning package 1289900806
C:\Program Files\OCS Inventory Agent\download    -    
Everything done...
C:\Program Files\OCS Inventory Agent\download    -    End of work

Cependant, via le naviguateur, aprés avoir accepté le certificat, j'accède bien au fichier info

Last edited by teckboy62 (2010-11-17 09:41:25)

Offline

#25 2010-11-17 09:41:09

bezourox
OCS Team
Registered: 2009-11-17
Posts: 1,619
Website

Re: You don't have permission to access /download/ on this server.

Bonjour,

1. Faire ce que dit Frank, à savoir :
   > vérifier la présence du "cacert.pem" dans le dossier "C:\Program Files\OCS Inventory Agent\"
   > Nous faire ici un copier/coller du log de la machine "host.log" qui se trouve dans le même dossier
2. nous faire ici un copier/coller du log des téléchargements de paquets "download.log" toujours dans le même dossier
3. Nous préciser comment a été construit le paquet (méthode/nombre de fragments/etc...)
4. Nous préciser si tu as fait des tests sur une machine avant déploiement (si script .bat, l'exécution à la mano fonctionne t'elle ?)


IRC : #ocsinventory-ng @ chat.freenode.net
Documentation : http://wiki.ocsinventory-ng.org
Reference your company on http://www.ocsinventory-ng.org/en/commu … ences.html

Offline

Board footer

Powered by FluxBB