OCS Inventory NG Forums

OCS Inventory NG, an OpenSource computer inventory and package deployement system for Windows and Unix

You are not logged in.

#1 2007-07-05 15:02:06

fabio80
Member
Registered: 2007-05-03
Posts: 12

Access denied for user 'ocs'@'localhost' (using password: YES)

Hello guys, I've this problem since the reinstallation of OCS on a new server, every first time that I open the web browser and I go to the homepage of ocsinventory, I receive this error, but after a simple refresh of the page everything goes well. I checked on the dbconfig.php and other logs, without success. Just to let you know, my db is on a different server. 
Have you ever seen this error?
Regards
Fabio

Offline

#2 2008-03-26 08:58:24

andrasnet
Member
Registered: 2008-01-25
Posts: 9

Re: Access denied for user 'ocs'@'localhost' (using password: YES)

Hello,
I have the same problem, If anybody knows what settings should be made, I would appreciate your help. Locally everything works great but when I'm using an external database I receive the "ERROR: MySql connection problem Access denied for user 'inventory_user'@'localhost' (using password: YES)" message where the username is correct, After I reload the page, I can log in and I can access the database but agents can't connect to server.  I made the required changes for the database name and password update. There's some trick to connect to an external database? Please help or at least confirm that you're using OCS with an external DB without problems. I'm out of ideas. Thank you!
It's OCSNG ver. 1.01 for Linux.

Offline

#3 2008-03-26 11:27:44

freddan
Member
Registered: 2008-01-10
Posts: 19

Re: Access denied for user 'ocs'@'localhost' (using password: YES)

Hi! I had the same problem. Not sure however if your problem is the same. I installed phpmyadmin and compared my old working server with the new one. Then I installed some useraccounts manually (ocsweb) in phpmyadmin and after that it worked fine.

Offline

#4 2008-03-26 12:16:27

andrasnet
Member
Registered: 2008-01-25
Posts: 9

Re: Access denied for user 'ocs'@'localhost' (using password: YES)

Hi, thank you for your quick answer!
In the meantime I solved the agents communication problem with the server but the message still appears. I think there's not an account problem, if it would be I would not be able to access the database. Anyway, I will create a user like the default one (user: ocs, passwd: ocs) to make a try.
The application is great, but the settings should be in a single file or more easier to locate where changes should be made.

Offline

#5 2008-03-26 17:40:20

mjsilva
Member
Registered: 2007-11-07
Posts: 9

Re: Access denied for user 'ocs'@'localhost' (using password: YES)

I have the same problem after upgrading. I solved with user root and no password.

Offline

#6 2008-04-03 09:01:51

andrasnet
Member
Registered: 2008-01-25
Posts: 9

Re: Access denied for user 'ocs'@'localhost' (using password: YES)

Hello,
It's Ok with the ocs user and the same password, but I would like to use at least a different password, not the default one. There is certainly a file to edit  or some setting that should be changed. I have only found the ocsinventory.conf, z-ocsinventory-server.conf, dbconfig.inc.php files containing infos about DB connection. Do you know some other locations where changes should be applied? Thank you!

Offline

#7 2008-04-03 13:48:05

dliroulet
OCS Team
From: Toulouse, France
Registered: 2007-03-12
Posts: 1,834
Website

Re: Access denied for user 'ocs'@'localhost' (using password: YES)

Hi.

No more files, except ipdiscover-util.pl in admin console files

Cheers


IRC Channel #ocsinventory-ng on FreeNode

Offline

#8 2008-04-03 15:55:42

andrasnet
Member
Registered: 2008-01-25
Posts: 9

Re: Access denied for user 'ocs'@'localhost' (using password: YES)

Thank you, dliroulet, I forgot to mention that file. In this case I don't know what's wrong with my settings, I updated the connection data in all these files....

Offline

#9 2008-04-06 19:49:37

dliroulet
OCS Team
From: Toulouse, France
Registered: 2007-03-12
Posts: 1,834
Website

Re: Access denied for user 'ocs'@'localhost' (using password: YES)

Hi.

Have you changed the password for user ocs@localhost, or for user ocs@computername ?

cheers


IRC Channel #ocsinventory-ng on FreeNode

Offline

#10 2008-04-07 09:38:20

andrasnet
Member
Registered: 2008-01-25
Posts: 9

Re: Access denied for user 'ocs'@'localhost' (using password: YES)

Hello, dliroulet!
I don't know if it was a suggestion or only a question, but I have changed the password for the ocs@localhost and now I don't receive the error message. That's great but I would be curious why the OCS is still communicating with the local mysql DB when I don't use it anymore (theoretically)? Thank you!

Offline

#11 2008-04-29 12:01:29

leo_hen_oli
Member
Registered: 2008-04-28
Posts: 2

Re: Access denied for user 'ocs'@'localhost' (using password: YES)

hI,

I had the same problem. What i did: i´ve installed the MySQLAdministrator and change the created the user ocs with hostname localhost. Then, the interface come up and i i logged with root to perform the OCS DATABASE creation.

This problem was resolved. Now i have others and will publish them in the forum,

Offline

Board footer

Powered by FluxBB

Serveur dédié, hébergement web, infogérance et nom  de domaine - NFrance Conseil